IonCube Loader is a software instrument, that's needed to run files which are protected with ionCube PHP Encoder. The latter is an app that is used to make PHP code human unreadable, in order to protect it from reverse engineering and illegal usage. A number of script-driven apps, in particular message boards, content management systems and e-commerce solutions are protected with ionCube PHP Encoder, which means that when you buy a script and you find that ionCube is one of the hosting environment prerequisites, you should ensure that your web hosting server has the tool pre-installed. While it is not that difficult to install it when you have your own server, it is close to impossible to do that on a shared web hosting server since the PHP environment will have to be precompiled and all of the clients on the server shall be affected.

IonCube in Cloud Web Hosting

When you aquire a Linux cloud web hosting service through us, it'll be created on our custom cloud platform where ionCube Loader is already set up, so you won't have any problems to manage any script application that needs the instrument so as to run properly. We also offer you a few different versions of PHP, therefore in case you change the version, you'll need to activate ionCube once again. Our platform remembers the adjustments you make, and in case you move back to the previous release of PHP which was active for your account, ionCube Loader will already be activated. The PHP version and the ionCube instrument can be managed through the PHP Configuration area of our Hepsia website hosting Control Panel. Any change that you make takes literally just a single click and it'll take effect instantly.

IonCube in Semi-dedicated Servers

In case you obtain a semi-dedicated server package from us, you will be able to employ any kind of script-driven application that needs ionCube Loader since the tool is installed on all of the servers which are a part of our state-of-the-art cloud hosting platform. Furthermore, we support various releases of PHP, so if you move from PHP 4 to 5.2 or 5.3, for instance, you can activate ionCube for that particular version with only a click from your Hepsia Control Panel. Our system will remember your decision, so in case you switch back to the earlier release of PHP, the software tool will already be active. For more experienced users, we also provide the option to pick the PHP version and whether ionCube will be active or not for a particular domain name without altering the settings for the entire website hosting account. This can be done by putting a php.ini file inside a domain folder with a couple of lines of program code.